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9 Interactive Plot  

The Interactive Plot program is a program module that may be started by other Warrior programs, 
such as Acquisition or Recalculation. It may also be used independently to generate log plots on the 
screen or to the hardcopy device(s). It is also used for adding individual banners (inserts) and 
annotations (e.g. curve labels) to a log pass. Note that multiple copies of Interactive Plot may be 
running at the same time, such that the system may be plotting dataset A to the screen, dataset B to 
one hardcopy device and dataset C to a second hardcopy device. 
Double-click the Interactive Plot icon in the Warrior shortcut folder or select Action /Screen Plot  in 
Warrior Logging System 

 
FIG: 9.1 Interactive Plot 

9.1 File  
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FIG: 9.2 Select Action/Screen Plot 

9.1.1 Select Dataset 
Select Dataset from Database for specifically Log pass 
Selection of the database and dataset containing the data to be plotted. A standard Windows file 
selection box appears, see Figure 9.3 The required database is selected by double-clicking the 
selection, or highlighting it and clicking OK.

FIG: 9.3 Select Data Base 

9.1.2 Import ASCII Files 
See Section 12.3.1 Read ASCII data into Warrior 

9.1.3 Export to LAS 
See section 12.1.1 Export to LAS Format 

From interactive plot select Action->Screen Plot  menu. In addition double-clicking in the scales area 
of the interactive plot window will also start the Format Editor. 

 

FIG: 9.4 Select Action/Screen Plot 



234Warrior Software Version 7.0 Standard Cased Hole 

 

FIG: 9.5 Double Click over the header  

 

FIG: 9.6 Edit Presentation 
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9.2 Options 
Allows selection of various presentation options as shown below. 
Edit / Log Format… 
Provides rapid access to the Log Format Editor. When the Format Editor is invoked from Interactive 
Plot, changing the log format and saving it causes the active screen plots to be repotted with the new 
format. Note that many screen plots may be overlaid on each other at any one time. If a large number 
plots are present, a noticeable delay will occur while all are repotted. 

 

FIG: 9.7 Options 

Start and Stop depths can be selected or the full range of the database can be selected using the 
Maximize button. 
Alternative presentation files may be selected using the Browse button, which brings up a standard 
file selection box. Warrior log format information is contained in individual files with a prs extension. 
These files are created or edited using the Log Format Editor program. 
Note that a selection can be made to Use a private copy of presentation with this log . This 
embeds the current presentation file in the database so that the database can be archived complete 
with its presentation or sent to other Warrior systems without having to remember to send the 
presentation file along with it. Also, if the presentation is embedded and it is subsequently edited from 
Interactive Plot, the edit will only take place on the embedded copy, not on the original file. English
or Metric depth units may be selected, or Time can be used as a reference. The log may be plotted 
Up or Down . The log data units may be selected as English or Metric , or you may define a hybrid 
system. The User Defined units setup is done from with the Control Panel . Whenever a parameter 
in the Options window is changed, the current log screen plot(s) will be redrawn with the new option. 

When an option is changed, ALL interactive plots are redrawn. This can be a 
heavy load on the computer if a large number of CBL-VDL plots are currently on 
the screen and with a slow machine it may look as though the system has halted! 
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Select the depth to Start/Stop to Plot the LOG 

Select presentation from the Warrior\Format (directory). 

Select Vertical Scale by default is 1:240 (5” = 100’) or (1’ = 240 ‘) 

Exit
Closes the currently selected Interactive Plot. 

Annotations… 
Allow you to place annotations, curve labels and graphical objects on the log. 

9.3 Annotate the LOG
Scroll the log to the area where annotations are required and select Annotate from the Action menu. 
Note that annotations may be placed on the log even whilst logging. Simply 'Pause' the scrolling log, 
scroll back to the area where the annotations are to be inserted, place the required annotations and 
'Unpause' to return to the current logging depth. 

9.4 Create a LOG Banner (Insert) 
Ensure that the pass, to which the banner is to be attached, is selected in the active plot window. 
Select Edit/Log Banner , and if required a database and dataset. 

FIG: 9.8 Log Banner Insert Window 

Clicking on the File menu and clicking the Select Format option can select the format of the Log 
Banner. There are a number of Log Banner formats (*.Wlb) to choose from. Select the most 
appropriate format and the edit the details by clicking on relevant areas within the window. 

FIG: 9.9 Edit Log Annotations 
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9.5 Screen Plot 
Select a database and dataset Go to Options and select the depth interval, plot presentation, etc.. Go 
to Action and select Screen Plot. The log will appear as below. 
The plot may be paused by using the Pause button and terminated by reselecting Screen Plot . The 
plot may be paused at any time and the scroll bar, used to move back through the log to any zone of 
interest. When moving the scroll bar, the actual log depth, corresponding to the scroll bar position, is 
indicated in a box in the centre of the log plot window. A popup window opens by right-clicking on the 
plot, displaying all the curve's values at the mouse position  
Note that the plot may be paused (or terminated) during logging without any loss of data, and 
subsequently returned to the current logging depth. 
A plot may also be generated by directly selecting Screen Plot under the Action menu. A file selection 
box will be displayed. 
Select a file in the standard Windows manner. If a presentation file is associated with the selected 
database, the plot will start immediately; otherwise a file selection box will be presented. Selecting a 
suitable presentation file will cause the plot to commence. 
Presentations may also be selected under the Options menu at any time, as previously described. 

9.6 Hardcopy 
Generates a hard copy plot to Warrior supported scrolling plotters devices and any Windows 
supported printer/plotter. Hardcopy can also generate PDF and TIFF files of the log, simply select 
the required option from the pulldown list. 

9.6.1 Plot a Hardcopy 
To plot a hardcopy, select Hardcopy… from the Actions menu. The selection of the database 
file, the presentation file and other menu options are identical to those of the screen plot. 
Selecting the Hardcopy… menu item brings up the following dialog box. 

FIG: 9.10 Hardcopy dialog Box 

There are normally several choices of printer. These include two classes of output. First, plotters 
supported by Warrior in the real-time scrolling mode, and second printers/plotters supported by 
Windows and installed on the system. Note that in the Windows mode, the output takes place in a 
paged manner, and that this mode is not suitable for use during logging. 
The number of copies and the media selection, for those printers that support it, can be chosen 
here. For those printers that support fanfold paper, Top of Form moves to the next fold. On some 
printers this will skip a fold so that new plots will start on an outside page when folded. 

9.6.2 Close the Current Plot & Select New Data 
Click on the plot selection, e.g. Screen Plot, and the plot is terminated. New Database file and 
Dataset selection may be made from the File menu, and presentation and other options may be 
chosen from the Options menu. 
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9.6.3 Make a TIFF File 
Install TIFF File as a Warrior printer with port name FILE: and driver None. You will be prompted for a 
file name for output. 

FIG: 9.11 Creating TIFF file 

By clicking on the Setup  button you can customize the page length, resolution and compression of 
the TIFF file. 
This is an extremely useful feature that enables log presentations to be sent as e-mail attachments 
or used for presentation purposes as they can be inserted into Word, Excel, Powerpoint, etc.. Most 
common graphic file viewers can also view them. 

9.6.4 Make a PDF File 
Install the Adobe Acrobat reader from the Warrior Software CD or Download the Adobe Acrobat 
Reader http://www.adobe.com/products/acrobat/readstep2.html .It is a free version. 
This option is exactly the same as the TIFF files procedure, although to install use PDF File, rather 
than TIFF File. The Setup is also slightly different as the compression options vary from those of the 
TIFF file. 
The Output type can be Color or monochrome 
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FIG: 9.12 PDF file settings 
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10 Plot Job Editor  

The Plot Job Editor is a program module, which enables the operator to assemble the various 
components (heading, log sections, etc.) of a well log into its final presentation. The resultant plot job 
information is saved in a well log database, usually alongside the log data. The Presentation Plot 
program uses the plot job information to create the graphical output to a plotter or other graphics 
device (fax file, etc.).
The Plot Job Editor is started from its icon in the Warrior group, the Presentation Plot File menu, or 
the Acquisition module Edit menu. (Video 10.1) 
Double click on the program group icon, the Acquisition Edit menu or the Presentation Plot File menu 

FIG: 10.1Select Plot Job Editor 
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FIG: 10.2 Select Plot Job 

10.1 File 

 

FIG: 10.3 File Menu 

The menu functions are as follows: 

10.1.1 New 
If a plot job is currently selected, New clears the editor for a new plot job.  

10.1.2 Open 
Displays the file selection window to allow the operator to select the database file containing the plot 
job to be edited. Note that plot job information is stored in the Warrior database file at the run level. 

10.1.3 Save 
After creating or editing the plot job it may be saved within a Warrior database file 
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10.1.4 Save As 
Allows a plot job to be edited and subsequently saved to new location with a different name. 

10.1.5 Screen Preview 
Starts Screen Preview of the selected plot job, see manual section on Presentation Plot. 

10.1.6 Hardcopy 
Displays a list of the plotters supported on the logging system. Selection of one of the plotters causes 
the plot job to be output to the hardcopy device (plotter). 

10.1.7 Exit 
Closes the Plot Job Editor 

10.2 Start the Plot Job Editor. 
When the selection of the items is complete the plot job data is saved in the Warrior database. 
If the Plot Job editor is invoked from within the Acquisition module the database path and name are 
set to be those of the current database. If invoked from elsewhere the full path must be entered by 
the user. (LEAVE NO ASTERISKS / WILDCARDS) The blank plot job appears as shown above. 

10.2.1 Change 
Changes plot job to be edited. 

10.2.2 Remove 
Removes the selected file from the plot job. 

10.2.3 Add 
To create a new plot job start with the Add button 

 

FIG: 10.4 Add File 

Add Displays the selection box containing types of files, which may be included in the plot job. 
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FIG: 10.5 Select the File to add 

Selecting a database file causes a list of plot jobs stored within the database to be displayed. 

 

FIG: 10.6 Select Database 
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FIG: 10.7 Select Plot Job 

 

FIG: 10.8 Select Heading 

Typically a log heading would be the first file to appear in the plot job. Click on Heading and, because 
headings are stored in the log databases, the database selection window is displayed. Select the 
database where the required heading is stored. A list of the headings stored in that database is 
displayed 
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FIG: 10.9 Select Database  

Select the required heading by double clicking, or highlighting and the OK button. The heading 
appears as an icon at the start of the plot job sequence, as shown below. 

 

FIG: 10.10 Select Plot Job Input 



246Warrior Software Version 7.0 Standard Cased Hole 

 

FIG: 10.11 Add Heading 

 

 

FIG: 10.12 Add Heading, Log Pass, Tool String, and Calibration Report 

Other files may be added as required in the order they are to appear on the final log presentation. 
To add a log section click on Single Log Pass and a list of the log passes in the currently selected 
database is displayed.  
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Selecting Multiple Log Passes allows the operator to select for inclusion the plot job several log 
passes at the same time. This is useful when there are many passes to be included, as with 
production logging.  
Other items from the type list may be added as required. Tool string diagrams and calibration 
reports are stored at the pass level, therefore when adding an item of these types, a list of the log 
passes is presented. 
In this way the items to be presented on log print are defined together with the order in which they 
are to appear. Each item appears as an icon as shown below. 

 

FIG: 10.13 Save 

Note that the plot job contains information concerning which files are to be plotted, in which order, 
and with what presentation. It does not contain the files themselves, therefore the files may be 
modified e.g. by adding annotations, without the need to recreate or modify the plot job itself. 
Selecting External PRN file allows the inclusion within the plot job of plot or print output from any 
Windows application. It is necessary that the material to be added to the plot job have been 
previously printed to a PRN file from the particular application. See Windows Help - Print to a file for 
details on how to do this. 
Upon completion of the plot job sequence the job may be plotted by choosing the Hardcopy option 
from the file menu. Alternatively the Presentation Plot program may be started from the Warrior 
program group (particularly if a Screen Preview is required). 
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FIG: 10.14 Select Screen Preview 

 

FIG: 10.15 Heading 
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FIG: 10.16 Log Pass 
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FIG: 10.17 Tool String Add  
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FIG: 10.18Calibration Report 

 

VIDEO: 10.1 Plot Job Editor 


